Checking connection...

Critical: Linux users at risk

1 February 2019  NEWS

We strongly urge all Linux users to install the latest Mullvad VPN app version and upgrade their Linux kernel to at least version 4.8.0 to ensure a working kill switch.

Linux kernels 4.4.0 and older do not support certain firewalls, which means that the Mullvad VPN app kill switch doesn't work for those kernels.
 

What do I do? Step-by-step guide

  1. First, install the newest Mullvad VPN app version.
  2. Run the app. If you have an unsupported Linux kernel, you will see an error message in the app.
    Mullvad VPN app showing a red error message
  3. If you see the error message, upgrade your kernel to 4.8.0 or newer.
  4. Reboot your computer and run the app. You should no longer see the warning message.

How do I upgrade my kernel?
If you're running Ubuntu 16.04, open a terminal and run this command:

sudo apt-get install linux-generic-hwe-16.04


More details

We only support app versions 2019.1 and newer. Therefore, we urge you to never downgrade to older versions.

Distributions that we have tested:

  • Ubuntu 14.04 and derivatives – you are affected
  • Ubuntu 16.04 and derivatives – you may be affected
  • Ubuntu 18.04, Debian 9+, Fedora 29+ – you are not affected.

Regardless of whichever distribution you have, follow the step-by-step guide above.

We have no plans of implementing workarounds for the affected kernel versions.

Windows and macOS users are not affected by this issue in any way, but we always encourage all users to upgrade to the latest app.