Der Mullvad-Blog

Halten Sie sich über Mullvad auf dem Laufenden. Neue App-Versionen, Sicherheitsupdates, Jobankündigungen – hier finden Sie alles.

News / Mullvad client — 2018/03/23

Ending support for older versions – update now!

Now is the time to download the latest version of the Mullvad client. We are ending support for old versions.

Mehr lesen

News / Privacy — 2018/03/22

Protect your privacy

When it comes to online browsing, there's more you can be doing to stay safe.

Mehr lesen

News — 2018/03/21

More locations, more languages

As we continue to expand our VPN network, you can now choose from 50 server locations in 31 countries worldwide. In addition, our website is now available in 13 languages, including Japanese and Italian.

Mehr lesen

Jobs — 2018/03/13

Hiring full-time front-end web developer/designer

We are looking for an experienced front-end developer equipped with both design and programming expertise to further develop Mullvad's website.

Mehr lesen

Jobs — 2018/03/13

Filled: Hiring full-time back-end developer

-- The position has been filled --

Mehr lesen

News / Mullvad VPN app — 2018/03/01

Get it now – official release of Mullvad VPN app for macOS

Today, our newly developed VPN app for macOS transitions from beta to stable release!

Mehr lesen

Mullvad VPN app — 2018/02/15

Download beta version 10 of VPN app

macOS users can now download the newest version of our desktop app. Remember to always have the latest beta; we do not support older versions.

Mehr lesen

News — 2018/02/13

Bitcoin Cash now accepted

You can now pay with Bitcoin Cash (BCH) to top up your VPN time with Mullvad.

Mehr lesen

Mullvad client — 2018/02/09

Client version 67 released

Windows and Linux users can now update to the newest version of our desktop client. Download version 67 now.

Mehr lesen

Mullvad VPN app — 2018/01/31

Download now – beta version 9 with maps

Get a whole new visual experience with our VPN app by downloading beta version 9 for macOS. Remember to always have the latest beta; we do not support older versions.

Mehr lesen